truck-trans-dodge
truck-logo-dodge
Search Messages :  

Ok so Clockspring Installation went ok...

From : jackvt80

Q: 2000 dodge 2500 cummins... first i got an airbag light then li ost cruise. so i purchased a clockspring from napa $43.00 and installed it today. pretty straightforward installation following the tsb in my previous post. btw in that post i asked how to remove the tilt knob. as tom said its threaded. in fact theres enough of a squared edge to slip a small box end in there for leverage. after reconnecting everything now i have cruise again but airbag light continues to illuminate. not much chance of something being connected wrong and i dont think anything is pinched. i guess it could be a bad clockspring. but before i take it to have it scanned i see there are two airbag fuses in my fusebox. the problem is they have what appears to be a tamper-proof plastic cover. no reference to it in my fsm. anybody know how to pull these fuses to check them thanks in advance. jack .

Replies:

From : maxpower

2000 dodge 2500 cummins... first i got an airbag light then li ost cruise. so i purchased a clockspring from napa $43.00 and installed it today. pretty straightforward installation following the tsb in my previous post. btw in that post i asked how to remove the tilt knob. as tom said its threaded. in fact theres enough of a squared edge to slip a small box end in there for leverage. after reconnecting everything now i have cruise again but airbag light continues to illuminate. not much chance of something being connected wrong and i dont think anything is pinched. i guess it could be a bad clockspring. but before i take it to have it scanned i see there are two airbag fuses in my fusebox. the problem is they have what appears to be a tamper-proof plastic cover. no reference to it in my fsm. anybody know how to pull these fuses to check them thanks in advance. jack if the lite does not go out remove the air bag and check to see that you did connect the connectors to the air bag. a very common mistake. glenn beasley chrysler tech .

From : maxpower

thanks glenn and bob. i unzipped everything again and checked all the connections. i even had to pry the airbag connector with a trim tool to get it off so i know it was on good. nevertheless i undid and redid all connections and zipped it back up. voila... no airbag light now for whatever reason. im guessing because i do a lot of salt water surf fishing i had some corrosion in the connections that needed a little back and forth to make better contact. thanks for the encouragement... you saved me some wasted money for a scan and maybe another clockspring replacement. jack if the lite does not go out remove the air bag and check to see that you did connect the connectors to the air bag. a very common mistake. glenn beasley chrysler tech- hide quoted text - - show quoted text - no problem just send me a few of those flonders that you catch .

From : jackvt80

thanks glenn and bob. i unzipped everything again and checked all the connections. i even had to pry the airbag connector with a trim tool to get it off so i know it was on good. nevertheless i undid and redid all connections and zipped it back up. voila... no airbag light now for whatever reason. im guessing because i do a lot of salt water surf fishing i had some corrosion in the connections that needed a little back and forth to make better contact. thanks for the encouragement... you saved me some wasted money for a scan and maybe another clockspring replacement. jack if the lite does not go out remove the air bag and check to see that you did connect the connectors to the air bag. a very common mistake. glenn beasley chrysler tech- hide quoted text - - show quoted text - .

From : bob az

after reconnecting everything now i have cruise again but airbag light continues to illuminate. =ef=bf=bdnot much chance of something bein= g connected wrong and i dont think anything is pinched. jack jack it will probably take a few start and stop cycles for the light to go out. bob az .