truck-trans-dodge
truck-logo-dodge
Search Messages :  

1998 RAM 1500 360 - Engine Dead, dash indicators whacky

From : budd cochrantim sell

Q: go find a used 88 w-series 4x4 and save yourself a few thousand dollars. budd .

Replies:

From : fmb

original battery i pulled my 98 quad cab 4x4 into a gas station today and the engine suddenly died. also the speedometer oil pressure gague and fuel meter started twitching and the digital odometer stopped displaying digits. the truck wont start but the engine cranks good. so the battery seems fine. i tried removing my battery from the system and jumping off another battery but that didnt help. the fuel pump makes no sound. all of the fuses are good. at 90k miles i want to blame it on a bad fuel pump but i cant get past the whacky instrument indicatons. my guess is that the computer suddenly died on me. does anyone have a better suggestion thanks tim denton tx .

From : tbone

it could be a pcm failure or a failure of one of its harnesses. get a good code reader and see if it can communicate with the pcm at all. another problem could be the ignition switch. find the fuse for the pcm and check for power there with the ignition in the run position. now power and you probably have a bad ignition switch. -- if at first you dont succeed youre not cut out for skydiving original battery i pulled my 98 quad cab 4x4 into a gas station today and the engine suddenly died. also the speedometer oil pressure gague and fuel meter started twitching and the digital odometer stopped displaying digits. the truck wont start but the engine cranks good. so the battery seems fine. i tried removing my battery from the system and jumping off another battery but that didnt help. the fuel pump makes no sound. all of the fuses are good. at 90k miles i want to blame it on a bad fuel pump but i cant get past the whacky instrument indicatons. my guess is that the computer suddenly died on me. does anyone have a better suggestion thanks tim denton tx .

From : me

i pulled my 98 quad cab 4x4 into a gas station today and the engine suddenly died. also the speedometer oil pressure gague and fuel meter started twitching and the digital odometer stopped displaying digits. the truck wont start but the engine cranks good. so the battery seems fine. i tried removing my battery from the system and jumping off another battery but that didnt help. the fuel pump makes no sound. all of the fuses are good. at 90k miles i want to blame it on a bad fuel pump but i cant get past the whacky instrument indicatons. my guess is that the computer suddenly died on me. does anyone have a better suggestion thanks tim denton tx tim check out this tsb http//dodgeram.info/tsb/2000/08-24-00.htm hope this helps -tony .

From : david

corroded ground connections there are several check all of them. david i pulled my 98 quad cab 4x4 into a gas station today and the engine suddenly died. also the speedometer oil pressure gague and fuel meter started twitching and the digital odometer stopped displaying digits. the truck wont start but the engine cranks good. so the battery seems fine. i tried removing my battery from the system and jumping off another battery but that didnt help. the fuel pump makes no sound. all of the fuses are good. at 90k miles i want to blame it on a bad fuel pump but i cant get past the whacky instrument indicatons. my guess is that the computer suddenly died on me. does anyone have a better suggestion thanks tim denton tx .